Adobe Photoshop

Da Wikipedia, l'enciclopedia libera.
Adobe Photoshop
Logo
Adobe Photoshop CS6 Extended su Windows 7

Adobe Photoshop CS6 Extended su Windows 7
Sviluppatore Adobe Systems
Ultima versione CC 14.1.2 (11 settembre 2013)
Sistema operativo Microsoft Windows (7 e 8)
Mac OS X
Genere Elaborazione digitale delle immagini
Computer grafica
Licenza Software proprietario
Lingua multilingua
Sito web www.adobe.com/products/photoshop

Adobe Photoshop è un software proprietario prodotto dalla Adobe Systems Incorporated specializzato nell'elaborazione di fotografie (fotoritocco) e, più in generale, di immagini digitali.

Questo programma è in grado di effettuare ritocchi di qualità professionale alle immagini, offrendo enormi possibilità creative grazie ai numerosi filtri e strumenti che permettono di emulare le tecniche utilizzate nei laboratori fotografici per il processamento delle immagini, le tecniche di pittura e di disegno. Un'importante funzione del programma è data dalla possibilità di lavorare con più livelli, permettendo di gestire separatamente le diverse componenti che costituiscono l'immagine principale.

È un software di grafica raster e in quanto tale si differenzia dai software di grafica vettoriale poiché agisce direttamente sui pixel, sebbene alcuni strumenti abbiano la possibilità di applicare gli algoritmi di Bézier (dalla versione CS2 sono stati introdotti dei miglioramenti per potenziarne la resa). Il software è espandibile mediante l'uso dei plug-in (come quelli in formato 8bf), che permettono di ampliarne le funzionalità.

Tra i plug-in, notevole importanza rivestono quelli che permettono al programma di leggere e scrivere nuovi formati di file come Adobe Camera Raw che permette di lavorare con file Raw prodotti da molte macchine fotografiche (tipicamente le reflex digitali) e con i file DNG. Adobe ha reso disponibili le specifiche del formato per la compilazione dei plug-in anche ad aziende di terze parti, creando quindi un mercato specifico di componenti per Photoshop, compresi anche pennelli, campioni di colore, pattern e sfumature, nonché di macro (comunemente chiamate "azioni"). Il 13 febbraio 2013 Adobe ha donato il codice sorgente della versione 1.0.1 al Computer History Museum di Mountain View[1].

Storia[modifica | modifica sorgente]

La prima versione di Photoshop risale al 1990 ad opera dei fratelli Knoll, figli di un fotografo, che idearono il programma per agevolare il lavoro del padre. Prende corpo dall'applicativo esistente Display[2] , sviluppato dal 1987 per MacPlus. La versione attualmente disponibile in italiano è la CC: la numerazione ordinaria del programma è stata modificata con la pubblicazione di Adobe Photoshop CS, che corrisponderebbe in realtà alla 8.0. La vecchia sigla ricorda che il software è parte integrante della Adobe Creative Suite.

A partire dalla versione 14.0 è stata utilizzata la sigla CC che fa riferimento all'Adobe Creative Cloud (che ha preso il posto della Creative Suite), un pacchetto di software per l'elaborazione grafica comprendente, oltre a Photoshop, anche Illustrator, InDesign, Version Cue, Bridge, Stock Photos (nel pacchetto standard), a cui si aggiungono GoLive e Acrobat Professional nella versione Premium. Tutti i componenti della Creative Cloud vengono venduti anche separatamente. Di Adobe Photoshop esiste anche una versione semplificata e più economica, chiamata Photoshop Elements: in passato, Adobe tentò di distribuire un'altra versione con ridotte funzionalità del programma, nota come Photoshop 5.0 LE (Light Edition), frequentemente distribuita in bundle con l'acquisto di alcuni prodotti di informatica come scanner o plotter di varie aziende.

Formato file[modifica | modifica sorgente]

Il PSD è un formato di file grafico di Adobe Photoshop, in grado di salvare un'immagine completa di tutti i livelli che la compongono. Un'immagine salvata in formato proprietario Adobe ha il vantaggio di essere lavorabile in fasi successive. Lo svantaggio è dato dalle dimensioni eccessive che non rendono agevole il suo trasferimento, se non usando idonee connessioni veloci o supporti adeguati. Si tratta di un formato particolarmente ricco di dettagli e informazioni sull'immagine. Rappresenta per la sua completezza un buon punto di partenza per i professionisti della grafica, per ottenere quasi qualsiasi altro tipo d'immagine. Il formato supporta anche le animazioni basate su livelli.

Cronologia delle versioni[modifica | modifica sorgente]

Segue l'elenco delle versioni di Adobe Photoshop.

Versione Sistema Operativo Codice Data di uscita Maggiori Cambiamenti
1.0 Mac OS 17 febbraio 1990
2.0 Mac OS Fast Eddy giugno 1991
  • Percorsi
2.0.1 Mac OS gennaio 1992
2.5 Mac OS Merlin novembre 1992
Windows Brimstone
2.5.1 Mac OS 1993
3.0 Mac OS Tiger Mountain settembre 1994
  • Tavolozza dei colori a schede
  • Livelli (aggiornamento fondamentale)
Windows, IRIX novembre 1994
4.0 Mac OS, Windows Big Electric Cat novembre 1996
  • Regolazione Livelli
  • Testi rieditabili (prima, il testo veniva subito rasterizzato)
4.0.1 Mac OS, Windows agosto 1997
5.0 Mac OS, Windows Strange Cargo maggio 1998
  • Undo multipli (Aggiunta la palette Storia)
  • Gestione del colore
5.0.1 Mac OS, Windows 1999
5.5 Mac OS, Windows febbraio 1999
  • Integrazione del programma ImageReady (per la creazione di gif animate, rollover e altre elaborazioni legate al web)
  • Filtro Estrai
  • Immagini vettoriali
6.0 Mac OS, Windows Venus in Furs settembre 2000
  • Strumento Pennello Correttivo
  • Filtro Fluidifica
  • Strumento editing testi "sul posto" (direttamente sul livello nell'area di disegno invece che in finestra separata)
6.0.1 Mac OS, Windows marzo 2001
  • Gestione della memoria migliorata
  • Strumento Contagocce ampliato
  • Salva/Esporta Tracciato di Ritaglio corretto
7.0 Mac OS/Mac OS X, Windows Liquid Sky marzo 2001
  • Testo completamente vettoriale
  • Pennello Correttivo potenziato
  • Nuovo sistema di pittura
7.0.1 Mac OS/Mac OS X, Windows agosto 2002
  • Camera RAW 1.x (plugin opzionale)
CS (8.0) Mac OS X, Windows Dark Matter ottobre 2003
  • Camera RAW 2.x
  • Comando Luci/Ombre (menu Immagine > Regolazioni)
  • Comando Corrispondenza colore (menu Immagine > Regolazioni)
  • Istogramma in tempo reale
  • Riconoscimento e blocco dell'importazione di immagini di banconote
CS2 (9.0) Mac OS X, Windows Space Monkey aprile 2005
  • Camera RAW 3.x
  • Oggetti avanzati
  • Comando Altera Immagine (menu Modifica > Trasforma)
  • Comando Pennello Correttivo al volo (menu Modifica > Trasforma)
  • Strumento Occhi Rossi(correzione della luce rossa dalle foto di occhi)
  • Filtro Fuoco Prospettico
  • Nuovo filtro di contrasto: Contrasta migliore
  • Fuoco prospettico
  • Gestione della memoria su sistemi a 64 bit (PowerPC G5 con Mac OS X 10.4)
  • Supporto all'HDRI High dynamic range imaging
  • Nuova applicazione Adobe Bridge
CS3 (10.0) Mac OS X (Universal Binary), Windows Red Pill dicembre 2006
  • Versione Universal Binary per computer Mac con processori PPC&Intel
  • Interfaccia utente rinnovata e semplificata
  • Aggiunto il plugin Camera Raw per l'editing su fotografie in formato raw
  • Migliorata l'integrazione con Adobe Bridge e gli altri software della Creative Suite
  • Strumenti di 3D compositing e texture editing
  • Filtri non distruttivi
  • Strumenti di misurazione 2D e 3D
CS4 (11.0) Mac OS X (Universal Binary), Windows Stonehenge ottobre 2008
  • Nuova interfaccia unificata con gli altri programmi della Creative Suite con supporto per le schede
  • Interfaccia ai livelli di regolazione più intuitiva
  • Filtri di Camera Raw in grado di operare su specifiche aree dell'immagine
  • Utilizzo della GPU per accelerare la visualizzazione e lo zoom delle immagini e l'anteprima dei filtri
  • Ridimensionamento delle immagini in base al contenuto (Content-Aware Scaling o Seam Carving)
  • Completo supporto per oggetti 3D e pittura su di essi (Photoshop Extended)
  • La versione a 64 bit viene commercializzata solo per Windows
CS5 (12.0) Mac OS X (Intel), Windows White Rabbit 12 aprile 2010 (presentazione ufficiale)

7 maggio 2010 (uscita sul mercato)

  • Versione nativa per computer Mac con processori Intel
  • Nuove funzionalità per selezione e scontorno[3]
  • Riempimento in base al contenuto (Content-Aware Fill)[4]
  • HDR Pro e HDR Toning
  • Strumento Alterazione marionetta per la deformazione delle immagini[5]
  • Pennello miscela colori e simulazione realistica pennelli secchi, umidi, bagnati
  • Estrusioni 3D semplificate con Repoussé (Extended)
  • Creazione veloce di ombre e di luci basate sull'immagine (Extended)
  • Ricca libreria di materiali 3D (Extended)
  • Editing del contenuto basato sul movimento (Extended)
  • Strumenti di analisi e misura delle immagini (Extended)
CS5.1 (12.1) Mac OS X (Intel), Windows 3 maggio 2011
  • Supporto per l'interazione con app per tablet.
CS6 (13.0) Mac OS X (Intel), Windows Superstition 21 marzo 2012 (diffusione beta pubblica)

23 aprile 2012 (presentazione ufficiale) 7 maggio 2012 (uscita sul mercato)

  • Nuova interfaccia utente scura in aggiunta alla consueta grigio chiaro.
  • Interfaccia utente riorganizzata e razionalizzata.
  • Salvataggio in background e opzione per il salvataggio automatico a intervalli regolari.
  • Nuovo Adobe Mercury Engine che utilizza la GPU su schede AMD tramite OpenCL oltre alle schede nVidia precedentemente supportate via CUDA e velocizza gli strumenti taglierina, trasformazione libera, alterazione marionetta, scala in base al contenuto ed il filtro fluidifica.
  • Strumenti toppa in base al contenuto e sposta in base al contenuto
  • Nuovo strumento taglierina interattivo
  • Visualizzazione a video di informazioni numeriche quando si modifica la dimensione di un pennello o si usano gli strumenti di trasformazione.
  • Nuovi filtri di sfocatura interattivi: campo sfoca (iris blur), sfocatura diaframma (field blur) e scostamento inclinazione (tilt shift)
  • Nuovo filtro interattivo per la simulazione di fonti di luce.
  • Nuove funzioni per i pennelli.
  • Funzioni di editing video migliorate e rese disponibili anche nell'edizione normale (non extended)
  • Funzioni 3D riorganizzate e applicabili in tempo reale che sostituiscono il pannello Repoussé della CS5 (solo versione extended)
CC (14.0) Mac OS X (Intel), Windows 18 giugno 2013
  • La nuova versione "CC" è inclusa in Creative Cloud, un sistema di aggiornamento e scaricamento dati automatico.
  • Filtro Nitidezza avanzata completamente rinnovato
  • Upsampling intelligente
  • Funzionalità estese incluse
  • Camera Raw 8 e supporto dei livelli
  • Rettangoli arrotondati modificabili
  • Selezione multipla di forme e tracciati
  • Riduzione effetto mosso della fotocamera
  • Supporto ampliato per oggetti avanzati
  • Disegno in 3D migliorato
  • Stili di testo migliorati
  • Possibilità di copiare gli attributi CSS
  • Azioni condizionali
  • Pannello Scena 3D migliorato
  • Funzioni ad alta produttività per il flusso di lavoro
  • Effetti 3D migliorati
  • Importazione di colori da file web
  • Opzioni anti-alias di sistema per il testo
  • Tecnologie basate sul contenuto
  • Mercury Graphics Engine
  • Strumenti avanzati per il design
  • Creazione video intuitiva
  • Galleria sfocatura
  • Strumenti 3D intuitivi e supporto DICOM
  • Salvataggio in background e recupero automatico
  • Miglioramento dei filtri Minimo e Massimo

Note[modifica | modifica sorgente]

  1. ^ (EN) Adobe Photoshop Source Code. URL consultato il 15 febbraio 2013.
  2. ^ http://www.studio7am.it/2011/06/la-storia-di-photoshop/
  3. ^ Adobe Photoshop CS5: Complex Selections made easy - YouTube
  4. ^ Adobe Photoshop CS5: Content-Aware Fill Sneak Peek - YouTube
  5. ^ Adobe Photoshop CS5: Puppet Warp Sneak Peek - YouTube

Voci correlate[modifica | modifica sorgente]

Altri progetti[modifica | modifica sorgente]

Collegamenti esterni[modifica | modifica sorgente]