Wikipedia:Officina

Da Wikipedia, l'enciclopedia libera.
(Reindirizzamento da Wikipedia:Richieste tecniche)


Torna a inizio pagina ↑
Abbreviazioni
WP:OF
WP:SALA MACCHINE

Officina

Officina

Benvenuto nell'Officina!

Se nella tua navigazione o durante la modifica delle nostre pagine hai incontrato qualche malfunzionamento o errore del software, o se pensi che il software attualmente utilizzato da Wikipedia (sempre in costante evoluzione e non esente da problemi) possa essere migliorato con qualche funzionalità tecnica che possa aiutare la nostra attività di utenti e contributori, ti preghiamo di segnalarcelo in questa pagina.

Aggiungi la tua segnalazione o spiega la tua idea in fondo alla pagina. Non lasciare e-mail ma aggiungi la tua firma copiando e incollando ~~~~ oppure cliccando sul tasto Insert-signature.png - Button sig.png (vedi Aiuto:Uso della firma).

Se cerchi informazioni sull'uso di Wikipedia guarda Aiuto:Aiuto e Aiuto:FAQ (vedi anche dove fare una domanda). Questa pagina non va usata per:


Fai click qui per aggiungere una nuova segnalazione e metti un titolo significativo
(tipo "Sarebbe utile uno strumento per fare la cosa X" o "Non riesco a visualizzare la tabella nella voce Y" e non "Ho un'idea geniale" o "Non funziona nulla")

Per le segnalazioni precedenti vedi Wikipedia:Richieste tecniche/Archivio e/o Wikipedia:Malfunzionamenti/Archivio.


Nuvola apps khelpcenter.pngSportello informazioni

WhatsApp e violazione di copyright?[modifica wikitesto]

Ho scoperto casualmente quella che potrebbe essere una piccola rogna e se io avessi ragione si connoterebbe come una violazione di copyright da parte di Wikipedia. Mi riferisco a quella funzionalità, presente ad esempio su WhatsApp o su Skype, che quando si inserisce un link, amplia la citazione inserendo qualche dato della pagina ed un immagine presente. Esempio. Purtroppo l'immagine dell'esempio, che è inserita con una licenza d'uso particolare, a mio avviso non avrebbe dovuto comparire, come ad esempio non compaiono gli screenshot copyrighted. Esempio di voce con screenshot. Mi pare quindi che ci sia un problema, ma non so quale sia il meccanismo che abiliti l'utilizzo delle immagini all'esterno; è possibile correggee la cosa senza troppe difficoltà? --Lepido (msg) 11:57, 2 lug 2017 (CEST)

La violazione di copyright dovrebbe essere loro, non di Wikipedia. È come quando siti esterni riproducono tutto il contenuto delle nostre voci fregandosene di quali immagini ci siano state concesse con licenza restrittiva e quali no. Noi siamo responsabili solo dei caricamenti effettuati sul nostro dominio.--Sakretsu (炸裂) 12:31, 2 lug 2017 (CEST)
"Ni"... (o "So") :-) Il fatto che alcune voci (quelle con gli Screenshot) funzionino bene ed altre (quelli ad es. con le copertine dei manga) non funzionino, mi fa pensare che siamo "noi" ad esporre non correttamente le immagini. Come ho detto, non so esattamente come funzioni la cosa: è l'agente esterno che con un parser controlla la licenza ed agisce di conseguenza o siamo "noi" a segnalare con "un qualcosa" se l'immagine può essere visualizzata o no? Ecco il punto.Se è il parser dell'agente esterno a fallire, allora non è un problema di Wikipedia, come dice [@ Sakretsu], altrimenti... --Lepido (msg) 13:47, 2 lug 2017 (CEST)
in realtà credo banalmente che il file da visualizzare venga preso dall'"Immagine della pagina" visibile anche cliccando su "Informazioni sulla pagina". qualche tempo fa leggevo su phab (o forse era ancora bugzilla) che la logica dietro l'estrazione dell'immagine era uno spaghetti code in PHP non più mantenuto. forse ci hanno rimesso la testa per le anteprime su mobile, ma non ho approfondito se c'è una logica di verifica della licenza o meno (o banalmente alcuni non vengono mostrati perché inseriti negli infobox senza il prefisso "File:", altri invece utilizzano ancora la vecchia sintassi). --valepert 15:10, 2 lug 2017 (CEST)

Problemi strani all'improvviso?[modifica wikitesto]

Verificate che non siano legati a questo cambiamento recente. Ciao, Elitre (WMF) (msg) 20:35, 5 lug 2017 (CEST)

Le pagine si caricano non completamente[modifica wikitesto]

Da ciò risultano almeno tre cose: 1. Non si vede la barra degli strumenti di modifica, 2. Non funziona la cerca interna, 3. Non si chiudono automaticamente i navbox collapsibili. La pagina può carricarsi al secondo-terzo-quarto tentativo, però è problema. Suppongo che sia legato a questi novi bottoni sotto la finestra modifica... In qualsiasi cosa c'è bisogno di correggerlo--Unikalinho (msg) 08:30, 6 lug 2017 (CEST)

mw:Help:Locating_broken_scripts se vuoi trovare il "colpevole". Elitre (WMF) (msg) 09:06, 6 lug 2017 (CEST)
[@ Elitre (WMF)] Mi sembra io abbia trovato: l'accessorio Permette di recuperare la definizione da Wikizionario tramite un doppio click fa problemi. Avendolo spento non osservo problemi. Verifica...--Unikalinho (msg) 08:29, 14 lug 2017 (CEST)
Lo so che soo ripetitivo, ma a volte le soluzioni più semplici sono anche quelle più efficaci :-) Hai provato a cancellare i file temporanei dal tuo browser? In caso di cambiamenti del codice Javascript dei siti, molte volte questa azione è risolutiva, perché evita che parti di codice "vecchio" residente nella propria cache si mescoli con il codice "nuovo". Da parte mia, da quando ho installato sul mio Chrome l'app "Cache Killer", certi problemi non li ho più riscontrati. --Lepido (msg) 09:16, 6 lug 2017 (CEST)
L'ho eliminato tutto -- all'inizio era davvero bene ma ora comincia di nuovo...--Unikalinho (msg) 12:40, 6 lug 2017 (CEST)
Anch'io, da mesi, non visualizzo più la barra degli strumenti di modifica. Fino a qualche giorno fa, riappariva ricaricando la pagina che intendevo modificare (magari riprovando più volte), ora non più. Tutto funziona invece correttamente se entro nella Wikipedia inglese, francese, tedesca e spagnola. Anche in Wikiquote nessun problema. È divenuto seccante anche firmare questo intervento. Sono costretto a ricopiare la sintassi "firma" dal messaggio precedente e a modificarla manualmente! Gaux (msg) 15:28, 7 lug 2017 (CEST)
Non posso verificare, visto che non avevo il problema in precedenza. Gaux, a te cambia qualcosa disabilitando l'accessorio Permette di recuperare la definizione da Wikizionario tramite un doppio click, se ce l'hai attivo? Elitre (WMF) (msg) 11:26, 14 lug 2017 (CEST)
GrazieElitre (WMF)! Ho disabilitato la casella che mi hai indicato (era attiva) e la barra degli strumenti di modifica è ricomparsa. Ho provato più volte e tutte con esito positivo. Ho provato a reinserire il flag nella casella e la barra nuovamente scompariva!! Disabilitandola, di nuovo tutto OK. Ti ringrazio molto, editare senza la barra era veramente seccante. Ora posso anche firmare i miei interventi senza problemi! --Gaux (msg) 16:15, 14 lug 2017 (CEST)
Non ringraziare me, ma Unikalinho che l'ha scoperto. Adesso il prossimo passo è capire chi ha scritto quel gadget e comunicargli che deve fixarlo... Elitre (WMF) (msg) 17:02, 14 lug 2017 (CEST)
Fatto. Elitre (WMF) (msg) 17:34, 14 lug 2017 (CEST)
Segnalo che ho fatto presente nella talk della pagina di aiuto il problema; tuttavia a me (da mobile, schermata desktop) anche dopo aver disattivato il gadget la toolbar continua a non caricarsi al primo colpo.--Demart81 (Comunicazioni, insulti, ecc.) 19:16, 14 lug 2017 (CEST)
Forse c'è anche un altro accessorio (non usato da me) rotto...--Unikalinho (msg) 15:32, 15 lug 2017 (CEST)

Problema con login (risolto)[modifica wikitesto]

Salve, sono l'utente noto come "nineko", attivo soprattutto sulle Wikipedia Italiana ed Inglese, e sto avendo un problema bizzarro. Le mie impostazioni dei Cookies sono corrette, e soprattutto non le ho modificate di recente. Da sempre sono in grado di restare loggato e fare modifiche (si veda, ad esempio, l'elenco dei miei contributi in italiano ed in inglese). Tuttavia, stasera ho cliccato su un link di Wikidata per segnalare un errore ([1]), e da allora risulto sloggato ovunque. Se tento di riloggarmi vengo buttato di nuovo fuori non appena cambio pagina. Per puro scrupolo ho provato ad usare un altro browser (Chrome, mentre di solito uso Firefox), concedendo il massimo permesso alla creazione di Cookies, ma il problema si presenta lo stesso. O non mi fa loggare, o mi fa loggare per un istante e poi mi butta fuori di nuovo. Ho inoltre provato a cancellare tutti i Cookies pensando che potessero contenere dati errati, ma senza successo. Non vorrei che avere visitato Wikidata abbia corrotto qualche dato della mia sessione sul server o qualcosa del genere. Ho una buona esperienza informatica e sono stato io stesso amministratore e webmaster di vari siti, ma nonostante questo non so che altro poter fare, escludo che il problema sia sul mio lato perché si verifica, come detto, con due browsers diversi anche impostandoli nel modo più permissivo possibile per i Cookies. Grazie in anticipo a chi può identificare e risolvere il mio problema.
2.235.238.165 (msg) 01:12, 7 lug 2017 (CEST)

Risolto sulla Wikipedia inglese, a quanto pare è un problema noto.
Nineko (msg) 03:03, 7 lug 2017 (CEST)
[@ Nineko], magari se esponi in sunto o un riferimento alla soluzione può servire a chi ha letto ed è stato in attesa senza allungare con anche io..anche io. Un pò come affiggere manifesti del gatto smarrito e poi lasciarli appesi @#]. GRazie ☼Windino☼ [Rec] 08:07, 7 lug 2017 (CEST)
Avevo già pensato di condividere la soluzione con il resto del mondo: le parole "sulla Wikipedia inglese" nel mio intervento precedente sono un Wikilink che rimanda a questa pagina, la quale pagina a sua volta rimanda a https://phabricator.wikimedia.org/T169261, dove vengono analizzate le cause da alcuni giorni, non conoscevo l'esistenza di quella pagina, altrimenti non avrei aperto una segnalazione. Visitando questi due link si possono trovare tutte le indicazioni utili (sia della causa sia della soluzione), ma posso fare un brevissimo sunto a beneficio di chi non parla inglese o di chi non è interessato ai dettagli tecnici: il problema è effettivamente sul lato di Wikimedia, e può essere aggirato facendo il login su un progetto di Wikimedia mai usato prima, nel mio caso mi hanno consigliato il Wikivoyage cinese.
Cambio l'header di questa discussione aggiungendo la parola (risolto) così da non fuorviare altra gente.
Nineko (msg) 09:06, 7 lug 2017 (CEST)
Grazie.--☼Windino☼ [Rec] 13:53, 7 lug 2017 (CEST)

Problema con "Verifica requisiti di voto"[modifica wikitesto]

Da una veloce ricerca negli archivi, non sembra essere mai stato segnalato. Utilizzando la funzione "Verifica requisiti di voto" (attivabile sotto Preferenze>>Accessori>>Link laterali) per alcuni utenti (quale, ad esempio, il sottoscritto o Pil56) si ottiene un "l'utente non è registrato". Il problema mi sembra dovuto a un valore ("registration") non restituito dalla prima chiamata json. Possibile che per le utenze più vecchie tale valore non sia stato valorizzato (...e che non sia possibile valorizzarlo)? --LEOSCHUMY (scrivimi qui) 12:23, 7 lug 2017 (CEST)

Errore lua con mw.wikibase.getEntityObject[modifica wikitesto]

Ieri, nel leggere una normale voce (Alfonso II di Napoli) ho riscontrato la presenza del seguente errore: Errore Lua in mw.wikibase.entity.lua alla linea 34: The entity data must be a table obtained via mw.wikibase.getEntityObject. Al momento non è più presente nella voce in oggetto, ma è comunque riscontrabile in un considerevole numero di voci. A quanto mi sembra di capire, l'errore è generato direttamente da wikidata: lo si trova infatti in template, quali {{interprogetto}} e {{divisione amministrativa}}, che prendono da lì parte dei loro dati. Oltretutto, se in alcune voci è questione di una riga, altre voci come questa sono un macello di rosso. Non lo avevo mai notato, quindi mi viene da pensare che sia dovuto a qualche recente aggiornamento o modifica, magari appunto su wikidata; non ho nemmeno trovato discussioni al riguardo. Di cosa si tratta effettivamente?--Daimona Eaytoy (Scrivimi!) 20:12, 12 lug 2017 (CEST)

Se ne sta parlando qua --ValterVB (msg) 20:22, 12 lug 2017 (CEST)

Utenza che si disconnette continuamente[modifica wikitesto]

Buongiorno! Segnalo questa richiesta all'Oracolo. --Syrio posso aiutare? 10:25, 13 lug 2017 (CEST)

Sembra un problema tutto "nostro"[modifica wikitesto]

Da ieri sera e fino ad ora, l'icona "i tuoi avvisi" (ovvero quelli riportati in cima alla pagina con l'icona appena vicino il nome utente e con il relativo "numero" che segnala la quantità degli avvisi da leggere) non funziona (se faccio click non si apre). Strano però, che se lo faccio da altre wiki, l'apertura è immediata. Qualcuno ha riscontrato per caso lo stesso problema? --Fcarbonara (msg) 11:26, 16 lug 2017 (CET)

Ricerca migliorata negli archivi di pagine cancellate[modifica wikitesto]

Durante il Wikimedia Hackathon 2016 il Discovery team ha lavorato su uno degli strumenti della lista desideri della community, l'l'abilitazione della ricerca di archivi di pagine cancellate. Questa funzionalità è ora pronta per la distribuzione e verrà abilitata su tutte le wiki, eccetto Wikidata.

Al momento, la funzionalità è dietro un flag - per usarla, vai nella pagina Special:Undelete e aggiungi &fuzzy=1 all'URL, in questo modo: https://test.wikipedia.org/w/index.php?title=Special%3AUndelete&fuzzy=1. Quindi, cerca la pagina che ti interessa. Dovrebbero esserci molti più risultati di prima, per l'utilizzo dell'indicizzazione ElasticSearch (attraverso l'estensione CirrusSearch).

Pianifichiamo di abilitare la ricerca migliorata su tutte le wiki molto presto (attorno al 1º agosto 2017). Se hai delle obiezioni, scrivi al Discovery team via email o sulla pagina di discussione di questo annuncio. Come molti dei parametri di configurazione Mediawiki, la funzionalità deve essere configurata per ogni wiki. Una volta che la ricerca migliorata viene attivata di default, puoi ancora accedere alla vecchia modalità utilizzando &fuzzy=0 nell'URL, così: https://test.wikipedia.org/w/index.php?title=Special%3AUndelete&fuzzy=0

Siccome Special:Undelete è una funzionalità solo per gli amministratori, questa capacità di ricerca sarà disponibile solo agli amministratori.

Grazie! CKoerner (WMF) (talk) 20:32, 25 lug 2017 (CEST)

Estensione per funz. parser relative alle categorie[modifica wikitesto]

Nell'ambito di una manutenzione via bot di errori tipici nelle prime versioni di pagine create da utenti meno esperti, ho deciso di provare a risolvere (tra le altre cose) i problemi alle categorie. In particolare un problema degno di nota (e non solo tra le pagine appena create) è la compresenza di una categoria specifica e di una categoria madre di quest'ultima; ad esempio di CAT:Pianisti ungheresi e CAT:Ungheresi. Tuttavia non conosco alcun modo per sapere, utilizzando AWB, quale sia un'eventuale relazione tra due categorie. Frucando su mediawiki ho trovato questa estensione che aggiunge un paio di funzioni parser che permettono appunto di sapere la relazione esistente tra categorie. Per il lavoro che vorrei fare, ma anche per altri ambiti, sarebbe probabilmente molto utile avere una tale funzione parser, tuttavia ho un problema di fondo: non so esattamente come si possa installare tale estensione. Leggendo un po' di documentazione mi è sembrato di capire che debba farlo un amministratore o addirittura un dev e che l'abilitazione riguardi tutta it.wiki, ma ovviamente (e con discrete probabilità) potrei aver capito male. Che sia giusto o no, propongo qui la cosa per sapere se si possa implementare l'estensione ed eventualmente con quale iter. Grazie, --Daimona Eaytoy (Scrivimi!) 21:16, 3 lug 2017 (CEST)

(Sì, è una cosa che si installa in tutta it.wiki e nel caso può farlo solo un dev.) --Valerio Bozzolan (msg) 01:49, 4 lug 2017 (CEST)
[@ Valerio Bozzolan] Grazie mille per la risposta. In tal caso prima di aprire un task vado a verificare se c'è consenso altrove (ad es. Progetto categorie), anche se credo che l'aggiunta di tali funzioni non comporti di per sé controindicazioni.--Daimona Eaytoy (Scrivimi!) 09:43, 4 lug 2017 (CEST)

Grande bottone blu[modifica wikitesto]

L'avevo scritto anche altrove, e qualcuno ha verificato, e la mia collega un paio di thread più su lo sta ribadendo: visto che il cambiamento previsto non è solo grafico, per favore aiutate a verificare che non impatti su gadget/tool e quant'altro su questi lidi. Grazie! Elitre (WMF) (msg) 15:28, 4 lug 2017 (CEST)

e per vostra informazione il cambiamento è già attivo, se vedete qualcuno che si lamenta di bug strani, usate Phabricator (o al limite la talk della pagina qui sopra). Grazie, Elitre (WMF) (msg) 20:33, 5 lug 2017 (CEST)

pop up[modifica wikitesto]

Se si punta un link a un diff in crono si apre il pop up se si punta azioni esce un menu modifica| rolback| e se è il diff di una sola modifica esce anche send thanks. Ecco andrebbe tradotto. Thanks ops.. grazie--Pierpao.lo (listening) 22:06, 21 lug 2017 (CEST)

[@ Pierpao] il gadget è importato da en.wiki, dove ho fatto richiesta per abilitarne la traduzione. Nel frattempo almeno ora appare un messaggio in italiano se ci si sofferma col puntatore sopra.--Sakretsu (炸裂) 23:50, 23 lug 2017 (CEST)
✔ Fatto, ringraziamo i colleghi di en.wiki per la celere risposta.--Sakretsu (炸裂) 12:53, 25 lug 2017 (CEST)

Elenco puntato ed immagine[modifica wikitesto]

Tante volte mi ritrovo in pagine con situazioni del genere: nella sez. Monumenti e luoghi d'interesse della voce "Soletta (Svizzera)" vi è un'evidente interferenza tra elenco puntato ed immagine, con i punti dell'elenco che si sovrappongo all'immagine mentre il testo correttamente s'allinea a dx dell'img. Di solito risolvo il problema impaginando l'img con allineamento sulla dx, ma non sempre è possibile come in questo caso: ho un'infobox lungo e quindi l'img allineata a dx mi finirebbe alla fine della voce, quando tutto il corpo scritto della voce si concluderebbe invece prima.
Non si può in qualche modo risolvere il problema alla radice facendo sì che l'elenco puntato non si sovrapponga mai all'img in caso essa sia allineata a sx in quanto i punti si allineerebbero automaticamente a dx dell'img? -- Gi87 (msg) 10:32, 31 lug 2017 (CEST)

Dalle veloci verifiche che ho fatto è un problema che sembra interessare solo un solo browser (Edge) tra i più comuni. Provo a capire il perché e poi apro un bug. --Melos (msg) 11:26, 31 lug 2017 (CEST)
phab:T13782 --Melos (msg) 14:33, 31 lug 2017 (CEST)

Resa testi in immagini[modifica wikitesto]

Segnalo un problema di resa di testi nella creazione di immagini PNG come nella legenda del grafico a fianco creato da {{Grafico XY}}.

Il template utilizza il tag Graph. Il testo appare nitido quando si visualizza l'anteprima della pagina, ma diventa sfocato quando l'immagine viene effettivamente salvata. --M.casanova (msg) 11:27, 1 ago 2017 (CEST)

Può trattarsi di https://phabricator.wikimedia.org/T151654 ? Elitre (msg) 11:44, 1 ago 2017 (CEST)
Potrebbe essere. Grazie. Non mi sembra però ci sia una soluzione :) --M.casanova (msg) 11:54, 1 ago 2017 (CEST)
Aiuterebbe molto mettere degli screenshot di paragone in quel ticket però! Elitre (msg) 10:16, 3 ago 2017 (CEST)
[@ Elitre] Non so come funziona la gestione dei ticket :) Dove posso salvare le schermate? --M.casanova (msg) 10:41, 3 ago 2017 (CEST)
Scusa la fretta - credo che con le immagini puoi fare drag and drop nel ticket per caricarle, se hai un account Phabricator, ma se ti è più comodo mettile sulla piattaforma che preferisci che poi a trasferirle ci pensiamo. Elitre (msg) 12:12, 4 ago 2017 (CEST)
[@ Elitre] Vanno bene queste? anteprima e risultato --M.casanova (msg) 14:00, 4 ago 2017 (CEST)--M.casanova (msg) 14:00, 4 ago 2017 (CEST)

errore aprendo gli osservati speciali[modifica wikitesto]

Da un po' di tempo incappo relativamente spesso in questo errore

[WYCCrApAMFgAAGrWgrQAAABK] 2017-08-01 13:32:24: Errore irreversibile di tipo "Wikimedia\Rdbms\DBQueryError"

quando cerco di aprire la mia pagina degli osservati speciali. L'errore arriva dopo un buon minuto, come se la mia richiesta andasse in timeout. Poi la ricarico e tutto fila liscio.

Capita anche a voi? --Paginazero - Ø 15:37, 1 ago 2017 (CEST)

a me mi no. phabricator:T164314--Pierpao.lo (listening) 15:43, 1 ago 2017 (CEST)
Ho visto quel ticket, ma lo danno resolved... perplesso. --Paginazero - Ø 15:52, 1 ago 2017 (CEST)
Dal 30 giugno è stata applicata una modifica agli osservati speciali che potrebbe spiegare il cambiamento. Con queste impostazioni in Preferenze - Osservati speciali, l'errore non mi è mai comparso. Se ti ricapita anche così, dovresti provare a disattivare le funzionalità sperimentali e gli accessori come Novità o Non Seguire.--Sakretsu (炸裂) 16:13, 1 ago 2017 (CEST)
Grazie. L'unico filtro che avevo attivato in più rispetto al tuo screenshot era il "Nascondi le modifiche dei bot negli osservati speciali". Ora l'ho disattivato, vediamo che succede. --Paginazero - Ø 18:24, 1 ago 2017 (CEST)
Meraviglioso proprio quello che volevo attivare. Facci sapere. Comunque prima o poi questa migrazione a RemexHTML finirà e passeranno meno bot--Pierpao.lo (listening) 18:46, 1 ago 2017 (CEST)
[@ Paginazero] Bene, informiamo la WMF, bisognerebbe aggiornare le tabelle nel MySQL di wikipedia. --Los Vegas 22:08, 1 ago 2017 (CEST)
Succede anche a me ma pensavo dipendesse dal quantitativo di pagine negli OS, può essere? Immagino che anche pzero ne abbia un bel po'... --Civvì (Parliamone...) 22:13, 1 ago 2017 (CEST)
Dici che è ora che faccia un po' di pulizia? :-D --Paginazero - Ø 10:25, 2 ago 2017 (CEST)
io volevo copiare gli osservati di due colleghi se mi dite se sono pagine pubbliche e dove si trovano facciamo una controprova --Pierpao.lo (listening) 11:04, 2 ago 2017 (CEST)
Alla fine è quella spunta o no che cambia la situazione? I miei colleghi dovrebbero saperlo :) Elitre (WMF) (msg) 10:10, 3 ago 2017 (CEST)
[@ Pierpao] Gli "Osservati" sono privati, neppure agli amministratori, che come sappiamo hanno poteri pressoché divini :-) è dato di sapere che cosa un utente ha tra gli "osservati". Quindi, sempre che un collega non ti dia esplicitamente una lista testuale dei suoi osservati (questa è quella dell'utente che sta leggendo questo messaggio) tu non puoi importarli. --Lepido (msg) 13:05, 4 ago 2017 (CEST)
In realtà è possibile avendo il token che trovi nelle tue preferenze in fondo alla sezione "Osservati speciali" basta usare l'apposita API: questa sarebbe la chiamata API agli osservati speciali del mio BOT solo che al posto delle x dovresti mettere il token. Il risultato è proprio quello degli osservati speciali, mostra solo quelle modificate recentemente. --ValterVB (msg) 20:09, 4 ago 2017 (CEST)
[@ ValterVB] io il mio token al tuo bot non lo darò mai, che poi va a spifferare tutto a te... :-P A parte gli scherzi, l'accesso agli "osservati" da parte di qualcun altro è sempre su base volontaria, non può essere forzato da nessuno. --Lepido (msg) 20:48, 4 ago 2017 (CEST)
è comunque possibile usare un token solamente per scopi di test e poi reimpostarlo dopo averlo leakato, in modo che nel caso gli OS siano stati condivisi in buona fede per un'occasione quale la verifica di un bug, il legittimo proprietario può evitare che gli altri ficchino il naso sulla propria lista. :) --valepert 20:58, 4 ago 2017 (CEST)
Se non ricordo male ci sono stati utenti che hanno deciso di lasciare il progetto ma hanno lasciato i loro osservati speciali ad altri utenti di cui si fidavano. --ValterVB (msg) 21:30, 4 ago 2017 (CEST)

Beta conflitto di modifiche su due colonne: problemi con la firma[modifica wikitesto]

Usando il nuovo gadget "Conflitto di modifiche su due colonne" ho riscontrato un fastidioso problema. Quando firmo NON in discussione (come per esempio nel caso delle PDC, del bar, delle votazioni per gli admin) ogni tanto (non nel 100% dei casi) mi viene presentata una schermata che mi mostra la mia firma e le --~~~~ dicendo che c'è stato un conflitto di modifiche con me stesso. Andrebbe aperto un task su Phabricator? C'è qualcun'altro con questo stesso problema? Questo commento senza la firma utente è stato inserito da Ferdi2005 (discussioni · contributi) 22:28, 1 ago 2017.

Penso che si possa segnalare qui. La prossima volta che ti capita, se fai uno screenshot dell'errore e glielo mostri, li aiuti a capire meglio di che si tratta.--Sakretsu (炸裂) 22:55, 1 ago 2017 (CEST)
[@ Sakrestu] So che esiste la pagina apposita, ma voglio sapere se ci sia qualcun'altro con il mio stesso problema--Ferdi2005 (Posta)Edizione 2000 12:42, 2 ago 2017 (CEST)
P.S. La firma prima era andata con le tidli sopra quindi mi sono dimenticato di firmare alla fine.--Ferdi2005 (Posta)Edizione 2000 12:43, 2 ago 2017 (CEST)

Gadget per diacritici attivo su it.wikisource[modifica wikitesto]

In it.wikisource corre un piccolo gadget capace di cancellare, modificare o aggiungere diacritici su qualsiasi carattere (sia che esista, sia che non esista un carattere unicode corrispondente alla combinazione carattere + diacritico). Molto, ma molto più comodo che ricercare faticosamente il carattere unicode giusto - alle volte, poi, senza trovarlo. E' basato sulla decomposizione/ricomposizione del carattere unicode in carattere ascii base + diacritico ricombinante utilizzando il metodo .normalize() di String; magari può suggerire qualcosa, sempre che non sia "scoperta dell'acqua calda". Vedete voi! --Alex_brollo Talk|Contrib 12:44, 2 ago 2017 (CEST)

quanti moduli abbiamo per i grafici?[modifica wikitesto]

segnalo una proposta di unione per quanto riguarda i moduli relativi alla creazione di grafici (ho pingato lì i due creatori, ma sono ben accetti tutti i wikipediani di buona volontà :)) --valepert 00:06, 3 ago 2017 (CEST)

Etiopia[modifica wikitesto]

La voce Etiopia, protetta, presenta dei problemi, anche se inspiegabilmente non tutti li visualizzano: all'inizio dell'incipit appare l'avviso: Il template {{Coord}} ha riscontrato degli errori (istruzioni): mw.wikibase.entity.lua:37: data.schemaVersion must be a number, got nil insteadErrore Lua in mw.wikibase.entity.lua alla linea 37: data.schemaVersion must be a number, got nil instead.

Inoltre, le coordinate non appaiono, l'interprogetto neppure, e ancora in fondo alla voce compare l'avviso: Errore Lua in mw.wikibase.entity.lua alla linea 37: data.schemaVersion must be a number, got nil instead.

Il problema è apparso dopo quest'apparentemente innocua modifica di Ruthven, che oltretutto dalla sua connessione non riesce a visualizzare alcun problema. Neppure dalla versione mobile appare alcun problema--Parma1983 00:45, 6 ago 2017 (CEST)

Il problema è purtroppo questo e non dipende da noi. Per far sparire gli errori serve un sysop che faccia un null edit alla voce.--Sakretsu (炸裂) 01:14, 6 ago 2017 (CEST)
Grazie. Allora pingo [@ Ruthven] affinché compia il null edit--Parma1983 01:23, 6 ago 2017 (CEST)
✔ Fatto -- g · ℵ (msg) 01:29, 6 ago 2017 (CEST)
Grazie, [@ Gianfranco] In effetti ora è tutto risolto--Parma1983 01:30, 6 ago 2017 (CEST)
Quella del sysop me la sono persa :) dovrebbe bastare un utente qualsisasi. --ValterVB (msg) 12:19, 6 ago 2017 (CEST)
Eh no, purtroppo fino a stamattina la voce era completamente protetta per via di un'edit war.--Sakretsu (炸裂) 12:26, 6 ago 2017 (CEST)

(a capo) Segnalo che, nell'interrogare il campo ricerca con Errore Lua ho ottenuto ben 7150 occorrenze di questo famigerato errore....dovrebbe intervenire qualche bot... o chiedere maggiori lumi a Ruthven.--Eumolpo (πῶς λέγεις; = che vuoi dire?) 17:48, 11 ago 2017 (CEST)

[@ Eumolpo] Probabilmente molte delle pagine della ricerca non hanno più l'errore perché già purgate, comunque se ne sta già occupando Valter con il suo bot e stanno cercando di risolvere su phabricator. Trovi tutti i dettagli del caso qui.--Daimona Eaytoy (Scrivimi!) 18:23, 11 ago 2017 (CEST)

Qual è la pagina Mediawiki giusta?[modifica wikitesto]

In fondo a tutte le pagine ci sono i link "Informativa sulla privacy| Informazioni su Wikipedia | Avvertenze | Sviluppatori | Dichiarazione sui cookie | Versione mobile". Qual è la pagina che gestisce questi link, da poter correggere il secondo link che attualmente è un redirect (da Wikipedia:A proposito di Wikipedia a Wikipedia:Sala stampa/Wikipedia)? --Superchilum(scrivimi) 09:28, 12 ago 2017 (CEST)

[@ Superchilum] Per quel link devi modificare MediaWiki:Aboutpage :) (istruzioni in mw:Manual:Footer). --Valerio Bozzolan (msg) 10:21, 12 ago 2017 (CEST)
[@ Valerio Bozzolan] grazie ;-) --Superchilum(scrivimi) 11:02, 12 ago 2017 (CEST)

Problema con gli osservati speciali[modifica wikitesto]

Buongiorno, qualcuno sa quale può essere il motivo per cui da ieri la pagina dei miei osservati speciali risulta costantemente vuota? Fino a due giorni fa vedevo regolarmente le modifiche fatte negli ultimi trenta giorni. Grazie! --Michele859 (msg) 15:57, 12 ago 2017 (CEST)

Prova a vedere qui se le tue pagine sono ancora registrate. Se la lista è vuota, potresti aver svuotato i tuoi osservati speciali per sbaglio.--Sakretsu (炸裂) 16:00, 12 ago 2017 (CEST)
Ho controllato ma le pagine risultano ancora tutte registrate. --Michele859 (msg) 16:05, 12 ago 2017 (CEST)
Negli Osservati Speciali controlla le spunte alle opzioni (in particolare rimuovi, se c'è, quella su "modifiche verificate") e premi il tasto "Mostra". Controlla anche le preferenze e gli accessori. Se non trovi nulla di anomalo, prova a catturare uno screenshot della pagina, caricarlo online (ad esempio su imgur) e mostrarlo qui.--Sakretsu (炸裂) 18:10, 12 ago 2017 (CEST)
Sembra che il problema fosse nelle preferenze. Problema risolto, grazie infinite.--Michele859 (msg) 18:25, 12 ago 2017 (CEST)

Errore su una vostra pagina[modifica wikitesto]

Salve, volevo segnalarvi che la pagina "https://it.wikipedia.org/wiki/Unlocker" riporta l'errore "Errore Lua in mw.wikibase.entity.lua alla linea 37: data.schemaVersion must be a number, got nil instead." Questo commento senza la firma utente è stato inserito da 151.61.105.95 (discussioni · contributi) 09:43, 13 ago 2017.

Errore rimosso.--Sakretsu (炸裂) 10:27, 13 ago 2017 (CEST)

Errore Lua[modifica wikitesto]

Ciao. Vorrei segnalare che l'errore Lua sta diffondendosi sempre più: 4 giorni fa erano presenti 7150 pagine, oggi addirittura 8964. Facendo un po' di patrolling mi rendo conto che molte delle modifiche alle voci dei comuni, Stati ecc comportano l'insorgere di tale errore--Parma1983 16:41, 15 ago 2017 (CEST)

Purtroppo al momento non c'è molto da fare. Vedi molti comuni perché il template {{Divisione amministrativa}} utilizza Wikidata ed è molto usato. --ValterVB (msg) 16:52, 15 ago 2017 (CEST)
Grazie, ValterVB. Quindi mi pare di capire che non si riesca a individuarne la causa--Parma1983 16:55, 15 ago 2017 (CEST)
Esatto, se mastichi un po' di inglese questa è la pagina su phabricator che traccia il problema. --ValterVB (msg) 17:25, 15 ago 2017 (CEST)
[@ ValterVB] L'ho letta in parte, anche perché di questioni tecniche ne capisco poco. Mi pare però di aver capito dalle ultime battute che il problema riguarda anche altre versioni (ma non tutte) e che l'unica soluzione per ora è far girare spesso il bot sulle pagine per pulirle, ma che ancora non si riesce a capirne il motivo e risolverlo. Speriamo si trovi presto una soluzione. E pensare che mi pare sia da poco che è iniziato--Parma1983 17:38, 15 ago 2017 (CEST)

Puntano qui in che ordine?[modifica wikitesto]

Secondo voi è possibile ordinare i Puntano qui secondo l'alfabeto invece che senza un criterio apparente o quanto meno dichiarato? In apparenza sembra che le liste vengano ordinati mettendo alla fine le più nuove o quelle in cui il wlink è stato attivato più di recente. In ogni caso, se un ordine c'è va dichiarata la ratio. Se un ordine non c'è, quanto meno ricorriamo all'alfabetico. (Grazie per l'officina, se ne sentiva il bisogno e spero che venga anche intesa come luogo di "redistribuzione" delle osservazioni di it.wiki verso phabricator e altri lidi difficili per gli utenti "umanisti". ;) pequod Ƿƿ 05:12, 16 ago 2017 (CEST)

Sono ordinati per oldid quindi più o meno sono ordinati per data di creazione. --ValterVB (msg) 09:20, 16 ago 2017 (CEST)
Link mw:Help:What links here/it Comunque non credo si possa cambiare l'ordine della pagina standard, sentiamo qualcuno più esperto--ValterVB (msg) 09:44, 16 ago 2017 (CEST)
[@ pequod76] leggendo il titolo della discussione mi è venuto un forte deja-vu. :) --valepert 18:56, 16 ago 2017 (CEST)

Le nuove pagine create da Sandbox personali non sono comprese fra le novità[modifica wikitesto]

Di solito creo le nuove voci dopo averle composte nella mia sandbox personale per poi spostarle nel namespace principale una volta finito. Ho notato però che le tutte le voci create in tal modo non sono incluse fra le "Nuove pagine" (qui). Per esempio, ieri 16 agosto ho creato le voci Giorgio Pestelli e Pestelli, la prima alle 12:24 utilizzando la sandbox e spostandola nel nomespace principale alle 16:16 (vedi); la seconda, una semplice pagina di disambiguazione, creata direttamente come tale alle 16:42. Nella citata pagina delle novità, compare solo quest'ultima, ma non la prima --TableDark (msg) 06:05, 17 ago 2017 (CEST)

È normale che sia così dato che spostare una voce non equivale a crearne un'altra.--Sakretsu (炸裂) 14:45, 17 ago 2017 (CEST)
E allora dovrebbe registrare la creazione della pagina sandbox. L'anomalia esiste solo per la pagina delle novità. La nuove voci vengono infatti registrate (correttamente, IMO) sia nella pagina dei contributi sia nell'elenco delle pagine create (qui), e la data della creazione è quella della pagina sandbox. Se esistono discordanze fra diverse pagine di servizio, evidentemente qualcuna non funziona bene --TableDark (msg) 15:31, 17 ago 2017 (CEST)
Sì, ma così il "rumore di fondo" che si genererebbe nella pagina sarebbe molto alto, perché un conto è vedere le nuove pagine (comprese le sandbox) di un utente e un altro è invece vedere la creazione di tutte le sandbox di tutti gli utenti. Forse la cosa migliore sarebbe che la pagina delle nuove voci registrasse l'ingresso in NS0 di una pagina, sia perché creata direttamente, sia perché proveniente da un altro NS (escludendo quindi gli spostamenti all'interno del NS0). --Lepido (msg) 18:13, 17 ago 2017 (CEST)

Speciale:PaginePiùRecenti[modifica wikitesto]

Da qui mi appare tutto bianco come se fosse tutto già verificato. Ieri sera mi è preso un colpo... mi era sembrato che qualcuno avesse verificato tutte le pagine. Invece quelle non verificate non sono evidenziate in giallo. --НУРшЯGIO(attenti all'alce bestadmin) 07:25, 18 ago 2017 (CEST)

C'è modo di controllare a che ora hanno aggiornato il software per vedere se il problema è legato? L'aggiornamento dovrebbero averlo fatto ieri. Non vorrei che non fosse l'unico problema, ieri ho avuto qualche problema con i filtri. --ValterVB (msg) 09:01, 18 ago 2017 (CEST)
Ho fatto una modifica di test in una voce a caso (o meglio, l'ha fatta il mio alter ego buono che può fare modifiche non autoverificate). Però le modifiche non verificate non avevano un punto esclamativo rosso nella crono? Non è che si sia perso per strada qualche marcatore delle modifiche non verificate? --Lepido (msg) 10:22, 19 ago 2017 (CEST)
forse il problema si tratta del bug?? o magari qualcuno sarà sfuggito alla manutenzione o all'aggiornamento?? --SurdusVII 11:42, 19 ago 2017 (CEST)

pagine nuove wiki[modifica wikitesto]

buongiorno, come state, cari wikicolleghi?? vi sono andate bene le ferie estive?? :) allora ecco che volevo chiedervi alcune domande, perchè ho alcuni problemi tecnici, probabilmente sarà il solito bug.. dunque, quando andate su Nuove pagine di solito ne trovate delle voci colorate di gialli.. invece nel mio caso li trovo tutti *bianchi* eppure quando controllo una voce sotto in fondo c'è la stringa di [Segna questa pagina come verificata] ma stranamente sulla lista dell'elenco non è colorato di giallo.. ne sapete come risolvere questo problema?? vi è mai capitata qualcosa del genere?? --SurdusVII 09:38, 19 ago 2017 (CEST)

Se leggi l'intervento subito sopra, se ne parla già. --Lepido (msg) 09:53, 19 ago 2017 (CEST)
[@ Lepido] grazie, vedo che non sono l'unico ad avere questo problema.. speriamo che prima o poi risolvano sto problema del bug.. --SurdusVII 10:08, 19 ago 2017 (CEST)

BUG: Autoformatter modifica i trattini in lineette enne anche quando non lo deve fare[modifica wikitesto]

Durante l'utilizzo della ottima estensione Autoformatter (vedi anche meta:User:TMg/autoFormatter) mi sono accorto che in alcuni casi trasforma automaticamente qualsiasi tipo di trattino in lineetta enne (compresi i wikilink ad altre voci, che diventano rossi). Per esempio, quando ho utilizzato autoformatter in questa modifica90170906 mi ha trasformato anche i collegamenti ed il link nel template {{torna a}} costringendomi a correggere manualmente. Andrebbe segnalato all'autore ma volevo prima capire se fosse una cosa normale o un bug eccezionale.--Ferdi2005 (Posta) 10:22, 21 ago 2017 (CEST)

[@ Ferdi2005] Non credo si tratti di un bug. La correzione nel {{Torna a}} (e in altri 7 punti) è dovuta al pezzo di codice sotto al commento "English Wikipedia also uses en dashes", che sostituisce i trattini fra due spazi con lineette enne. Non conosco il tedesco, né ho controllato altri pezzi di codice per cercare di capire il motivo, ma di certo la correzione può generare diversi errori. L'unico fix "tranquillo" che mi viene in mente (comunque da proporre all'autore) è di inserire un controllo della lingua nell'eseguire quella sostituzione, ovvero che venga controllato di essere su en.wiki, così come in altri punti (se non erro) viene controllato di essere su de o ru.--Daimona Eaytoy (Scrivimi!) 11:13, 21 ago 2017 (CEST)
[@ Daimona Eaytoy] Sarebbe la cosa più giusta mettere un controllo della lingua. Cercherò di scrivere all'autore, grazie.--Ferdi2005 (Posta) 11:20, 21 ago 2017 (CEST)

Link di Unità.tv[modifica wikitesto]

Salve, ho notato che la testata giornalistica Unità.tv è stata chiusa il primo Agosto di quest'anno. Vorrei chiedere in che modo Wikipedia dovrebbe agire per rimuovere tutti i collegamenti scaduti dalle fonti delle relative pagine.--Marcoscapin1994 (msg) 21:02, 21 ago 2017 (CEST)

Piuttosto bisogna vedere se sono archiviate delle versioni su Archive.org. Quand'è che fanno partire il bot miracoloso?--Ferdi2005 (Posta) 21:06, 21 ago 2017 (CEST)