Wikipedia:Bar/Discussioni/Problemi di caricamento col nuovo aggiornamento MW

Da Wikipedia, l'enciclopedia libera.

Problemi di caricamento col nuovo aggiornamento MW


Salve a tutti, scrivo qui perché purtroppo la precedente segnalazione era andata deserta e il problema, che sembrava risolto, mi si sta ora ripresentando.

Da mesi (forse anche un anno) notavo che qualsiasi pagina di Wikipedia mi si caricava in modo apparentemente completo, ma di fatto non era così. Ciò era evidente per esempio dai template cassettati che restavano aperti, oppure dalla casella di ricerca che non dava suggerimenti, oppure (questa la cosa più antipatica) una volta in casella modifica, non apparivano i pulsanti (grassetto, corsivo, firma...), causando grandissimo disagio. Per completare il caricamento occorreva sempre caricare la pagina 2-3 volte e farlo in modalità modifica è scomodissimo e non sempre efficace. Ne ho quindi dedotto che c'era qualcosa che ostacolava a un certo punto la "finalizzazione" del caricamento. Alcune settimane fa avevo deciso di fare delle prove e, tramite le preferenze, avevo iniziato a disattivare gruppi di accessori per capire se ce n'era qualcuno responsabile di ciò; disattivando un certo gruppo avevo notato che il problema si risolveva, così facendo prove di disattivazione selettiva, avevo trovato il responsabile: HotCat. Disattivando solo HotCat, il caricamento arriva a buon fine e il problema era perfettamente risolto, al punto che anche il mio modo di contribuire ne ha risentito positivamente.

Per fortuna è un accessorio che uso molto raramente, però è lo stesso un peccato. Non sono un tecnico, ma immagino che a un certo punto si possa essere creata una qualche incompatibilità fra il codice di HotCat e quello di qualche aggiornamento del software MediaWiki.

Fin qui tutto ok, se non che da pochissimo, credo in coincidenza con un altro aggiornamento del software MW, il problema si sta ripresentando identico. Stavolta però non so proprio cosa ci sia di incompatibile, ho provato a disattivare quasi tutto ma siamo punto e a capo.

Per completezza di informazione segnalo che utilizzo ancora (sì, ancora) il vecchio Monobook, ma disattivandolo le cose non sembrano cambiare. Uso Firefox, installato da zero su un'installazione pulita di Windows. Questo problema sta diventando penalizzante al punto da impedirmi di svolgere l'attività di amministratore, perché è snervante anche in cancellazione di una pagina trovarsi a dare l'OK a qualsiasi operazione voglia fare a causa del mancato completamento del caricamento. La cosa è assai grave, perché o trovo una soluzione a questo problema o mi vedrò costretto a rimettere le funzioni agli Steward (cosa che, per lo stesso motivo, avevo già pensato di fare in un paio di occasioni lo scorso anno). --Roberto Segnali all'Indiano 10:47, 28 apr 2017 (CEST)

Non credo che sia la soluzione, però ti dico che anch'io avevo cominciato ad avere problemi di caricamento alcuni mesi fa, però ero arrivato alla conclusione che non fosse tutta colpa di mediawiki ma (anche) del browser, tanto è vero che dopo molti anni d'uso ho abbandonato Firefox per passare a Chrome e con quest'ultimo le cose stanno funzionando benino. Se ne avessi la possibilità ti suggerirei di fare anche tu una prova in tal senso. --Pil56 (msg) 12:50, 28 apr 2017 (CEST)
Per completezza, questa è la precedente discussione: Wikipedia:Bar/Discussioni/Avvisi di sistema aumentati a dismisura.--Horcrux九十二 13:42, 28 apr 2017 (CEST)
P.S. A tal proposito, ho appena dovuto ricaricare la pagina perché non mi mostrava i pulstanti della toolbar per poter firmare...
Ah ecco, quindi non sono l'unico... No la discussione a cui mi riferivo è questa, andata deserta. --Roberto Segnali all'Indiano 14:27, 28 apr 2017 (CEST)
E' possibile anche una qualche interferenza con routine di antivirus?--Bramfab Discorriamo 17:20, 28 apr 2017 (CEST)
Lo escludo, non ci sono stati aggiornamenti (a parte le definizioni). La cosa si fa sempre peggio, ora bisogna ricaricare più volte, inoltre a quanto pare non sono l'unico ad avere questo problema. --Roberto Segnali all'Indiano 22:49, 28 apr 2017 (CEST)
Mi aggrego, ho dovuto ricaricare la finestra di modifica quattro volte solo per poter firmare questo messaggio :| --Syrio posso aiutare? 00:36, 29 apr 2017 (CEST)
Non saprei dire se è lo stesso problema; su en.wiki sono segnalati problemi con alcuni pezzi di codice deprecati/rimossi da Mediawiki, con una guida per trovare glis cript che non rispondono--Dr ζimbu (msg) 09:20, 29 apr 2017 (CEST)
Sì, sembra proprio lo stesso problema. Ma questo apre una questione ancora più grave: quasi tutti gli script deprecati non si trovano nei monobook.js/vector.js di ciascuno di noi, ma sparsi un po' in tutti gli accessori selezionabili dal menù Preferenze, che andrebbero quindi tutti revisionati alla ricerca delle parti di codice non più in uso. Io personalmente non ho molti accessori attivi, ma quelli che ho mi servono parecchio; d'altra parte, non ho le capacità di modificare i codici dei vari script. Servirebbe una specie di mini-festival per verificare almeno gli accessori più usati. Su en.wiki stanno appunto facendo così, ma da noi la gran parte degli accessori sono abbandonati a loro stessi da diversi anni. --Roberto Segnali all'Indiano 10:19, 29 apr 2017 (CEST)
Pensavo di essere l'unico (o quasi), ma vedo che sono in buona compagnia (ho visto che questa volta si è caricata la firma, ma prima dovevo andarla a copiare dalla sezione sotto le modifiche)--Klaudio (parla) 11:21, 29 apr 2017 (CEST)
La causa dei problemi di questi giorni è [BREAKING CHANGE] Oldest deprecated wikibits JavaScript now removed. Una brevissima sintesi dei problemi inaspettati: phabricator:T122755#3220618.
Premere F12 per aprire la console degli errori può aiutare a capire da dove venga il problema; togliere dal proprio common.js/monobook.js/altro ciò che non si usa aiuta a ridurre il lavoro. Nemo 12:10, 29 apr 2017 (CEST)
[@ Nemo_bis] Ho già provato quel sistema seguendo le istruzioni indicate, ma saltavano fuori una marea di errori associati a parametri assolutamente non legati a quelle pochissime cose che ho nel mio monobook.js. I problemi vengono senz'altro dagli accessori disponibili nelle preferenze e che molti di noi utilizza, che incorporano le parti di codice rimosse. --Roberto Segnali all'Indiano 14:59, 29 apr 2017 (CEST)
Sarebbe veramente "carino" se gli utenti che sanno dove mettere le mani dessero una mano a coloro che hanno solo bovinamentesemplicemente copiato il monobook.js e altro da utenti esperti e ora non hanno idea di dove mettere mano... Magari in una sezione apposita in Wikipedia:Malfunzionamenti? In cambio eterna gratitudine, immensa ammirazione e tanto wikilove. :-D (e intanto per firmare ho ricaricato tre volte) --Civvì (msg) 10:30, 30 apr 2017 (CEST)
Usate tutti quickedit? --Vito (msg) 10:49, 30 apr 2017 (CEST)
[× Conflitto di modifiche] Ho carinamente segnalato la questione ai malfunzionamenti. Il problema capita anche a me, con Safari, sia qui che su Commons. La cosa più noiosa è che la barra degli strumenti non si carica (uso il Visualizza anteprima varie volte per ricaricare una pagina completa di accessori). --Ruthven (msg) 10:57, 30 apr 2017 (CEST)
[@ Vituzzu] quickedit: io non l'ho mai usato ma ho lo stesso problema di chi mi ha preceduto; però non da tanto, solo da una settimana circa a questa parte. --Discanto ??? 17:01, 30 apr 2017 (CEST)
In pratica sono stati disabilitati un sacco di "elementi" js in un colpo solo, questo ha rotto una pletora di script. I problemi quindi non hanno un'unica origine né un'unica soluzione. Poi [@ rotpunkt] ci ha abbandonati e finisce che ci sto mettendo mano io che non c'entro nulla col settore! Prova a fare quanto spiegato qui e vediamo che errori hai. --Vito (msg) 17:09, 30 apr 2017 (CEST)
[@ Vituzzu] se vuoi ti posto da qualche parte (dimmi dove) anche i miei. Se per quickedit intendi il visualcoso, mai usato. Se non intendi quello, mai usato lo stesso perché non so neppure cosa intendi. --Roberto Segnali all'Indiano 18:55, 30 apr 2017 (CEST)
Anch'io ho rilevato i problemi di chi mi ha preceduto, anzi da ieri se n'è aggiunto un altro: devo cliccare 3/4 volte su "ricarica" di Firefox affinché mi funzioni LiveRC Versione 20071011/0.3.6 --Pracchia 78 (scrivimi) 19:04, 30 apr 2017 (CEST)
Devo ricaricare più volte perché tutto funzioni come si deve. Da stamattina lo faccio di default. Ma ancora una volta non riesco a firmare.

[↓↑ fuori crono] Firmo ora col copia&incolla --Pulciazzo (msg) 20:21, 30 apr 2017 (CEST)

Anche a me scomparsi i pulsanti del Monobook e non funziano più i link sotto la finestra modifica... Per intendersi, per mettere la firma devo fare copia e incolla adesso... --Sailko 20:06, 30 apr 2017 (CEST)
Come detto i problemi di uno sono diversi da quelli degli altri, per cercare di accorciare la catena di soluzioni fate così: rimuovete quanto possibile dalle vostre sottopagine .js (common.js, monobook.js e vector.js) sostituendolo coi relativi accessori in da speciale:preferenze. Per esempio due bottoni davano problemi e credo di averli sistemati per chi usa gli accessori, per gli altri dovrei andare di bot. Una volta passato tutto agli accessori provate a disattivarli uno per volta per isolare il problema e segnalarlo, al momento il grosso degli inghippi credo riguardi liveRC. --Vito (msg) 20:25, 30 apr 2017 (CEST)
Sentiamo anche che dice Jalo --Sailko 21:43, 30 apr 2017 (CEST)

Bisogna prima di tutto aggiornare MediaWiki:Gadgets-definition, questa è abbastanza facile: [1]. Ci sono anche degli accessori predefiniti che sono rotti... Vedi altro. Nemo 15:21, 1 mag 2017 (CEST)

Da venerdì scorso ho anche io lo stesso problema: non mi di carica la barra con i pulsanti B, I, firma... (se non dopo aver ricaricato 2-3 volte la pagina con F5) e anche quando ho qualche notifica spesso devo ricaricare la pagina 2-3 volte per poterla visualizzare. Credo di non avere nessuna sottopagina .js (se vado nelle mie preferenze utente i link alle pagine monobook.js, vector.js... sono tutti rossi perchè non li ho mai modificati) e non uso particolari gadget se non quelli che si possono selezionare barrando la casellina nella pagina accessori delle proprie preferenze utente, come il rilevatore di disambigua, quindi non saprei cosa provare a modificare. --Postcrosser (msg) 12:09, 2 mag 2017 (CEST)
Tutto a posto come prima, senza aver dovuto modificare niente da parte mia. Ringrazio chi ci ha messo mano :) Buona giornata --Sailko 09:49, 3 mag 2017 (CEST)
Nel mio caso assolutamente ancora no, anche se forse ora bastano "solo" 1-2 caricamenti invece dei 4-5 necessari prima. --Roberto Segnali all'Indiano 10:19, 3 mag 2017 (CEST)
Quoto l'"ancora no" di roberto e aggiungo che, a intermittenza, mi dà problemi anche sui popup che appaiono al passaggio sui wikilink. --Nicolabel 10:57, 3 mag 2017 (CEST)
Mi accodo ai non funziona. Con Firefox + XP è necessario ricaricare la pagina almeno una volta per i pulsanti e il menù di sinistra e mi pare che funzioni male anche la ricerca. Sembra che vada meno peggio con Firefox o ancora quasi meglio (ma mica tanto) con Edge entrambi in combinazione con Win 10 ma sinceramente non ci sto capendo un tubo e patrollare, lasciare un semplice avviso (ma non solo) è veramente faticoso. --Elwood (msg) 11:15, 3 mag 2017 (CEST)
Migliora leggeremente la situazione rimuovendo tutto ciò che aggiunge qualcosa al menu "navigazione" (pagine nuove, newuserscontribs ecc). E disattivando il live rc... --Civvì (msg) 12:10, 3 mag 2017 (CEST)
Quelle brutte cose come LiveRc non le adopero mica :) credo che c'entri casualmente, --Elwood (msg) 13:28, 3 mag 2017 (CEST)
Uso Firefox su Windows 10, il mio monobook.js contiene solo commenti e ho abilitato i pulsanti della toolbar e poco altro: mi associo a chi dice che il patrolling è diventata una grande prova di pazienza, questa firma l'ho aggiunta manualmente perché mi sono stancato di premere F5 per vedere se appaiono i pulsanti... Ah, la casella di ricerca funziona una volta su cinque, come segnalato da altri. --Bradipo Lento (msg) 12:17, 3 mag 2017 (CEST)

(Rientro) Se può essere utile, allego la lista coi miei pochi accessori attivi (appena 18 spunte), assieme ai link al mio common.js e al mio monobook.js. Ho già disabilitato il LiveRC e non è quello la causa del problema.

Preferenze
  • Ultima modifica. Aggiunge tab "ultima modifica"
  • Purge. Aggiunge tab "purge"
  • Aggiunge in alto il tab di modifica della sezione 0.
  • Collegamenti personali. Permette l'aggiunta di collegamenti personali nel menù "navigazione". (questi sono l'unica cosa presente nei miei common/monobook.js)
  • Contatore di visite. Aggiunge un link a https://tools.wmflabs.org/pageviews nel menù "strumenti" per visualizzare il numero di visite alla pagina
  • Bordi Arrotondati. Arrotonda i bordi dei menu di navigazione della barra laterale. È necessario un browser aggiornato.
  • In presenza di categorie nascoste aggiunge un link in fondo alla pagina per controllarne la visibilità.
  • Nasconde l'avviso "La modifica è stata salvata"
  • Aggiunge il link "Mappa" a lato delle coordinate visualizzate in alto a destra nelle voci georeferenziate, per aprire la mappa di OpenStreetMap.
  • ReferenceTooltips. Al passaggio del mouse su una nota visualizza una finestra di popup con le informazioni sul riferimento, senza doversi spostare alla sezione "Note".
  • WikiMiniAtlas. Aggiunge un link con l'icona del mondo a sinistra di tutte le coordinate create con il template Coord, per aprire una mappa interattiva.
  • Testo personale. Aggiunge alla toolbar di modifica una casella combinata per l'inserimento di testo personalizzato.
  • Aggiunge in alto a destra un link diretto alla chat di wikipedia. Vedi Aiuto:IRC
  • Aggiunge un pulsantino con immagine accanto al campo di motivazione della cancellazione per cancellare il testo ivi contenuto.
  • Aggiunge alla pagina Speciale:Ricerca una casella combinata per permettere l'uso di motori di ricerca esterni.
  • Aggiunge l'orologio in alto a destra
  • Rivelatore di disambigue. Evidenzia automaticamente tutti i link che puntano a pagine di disambiguazione, ma non quelli che puntano ai loro redirect
  • Rollback nascosti. Aggiunge un link in cima alle pagine dei contributi, che permette ai sysop di fare rollback massicci senza intasare le RC (come se fossero bot).

--Roberto Segnali all'Indiano 21:13, 3 mag 2017 (CEST)

Non abbiamo più nessun utente attivo che se ne intende di js?
Se ho ben capito la correzioni da fare sono indicate in mw:ResourceLoader/Legacy_JavaScript#wikibits.js ma non è banale --Bultro (m) 21:26, 3 mag 2017 (CEST)
Sono ripetitivo, però trovo poco comprensibile soprattutto il fatto che questi problemi pare siano relativi a Firefox; personalmente, da quando sono passato a Chrome (dopo almeno 10 anni di fedeltà a Firefox), tutte queste problematiche che avevo anch'io sono completamente sparite :-( --Pil56 (msg) 21:48, 3 mag 2017 (CEST)
Io ce li ho anche accedendo da Edge (Chrome non mi piace) e, cosa più importante, non si verificano accedendo a en.wiki e Meta da Firefox. --Roberto Segnali all'Indiano 21:51, 3 mag 2017 (CEST)
Sono sollevato di aver dedicato tre minuti alla ricerca di questa discussione e di essermi ritrovato in ottima compagnia. Ma, in sostanza, un utente "mediamente incapace" in informatica, ha speranze di uscirne senza dover cambiare browser? --Leo P. - Playball!. 22:02, 3 mag 2017 (CEST)
Non funziona di nuovo... si può fare un passo indietro, rimettere tutto come tre giorni fa? Grazie --Sailko 09:57, 5 mag 2017 (CEST)
No, non era in ordine tre giorni fa e non è in ordine tuttora. Anche a me capita che per un breve tempo "sembra" che la cosa si sia risolta, ma finché non si mette mano al codice js dei vari strumenti i problemi non spariranno. --Roberto Segnali all'Indiano 14:27, 6 mag 2017 (CEST)

[ Rientro] Io ho MS Windows 7 64 bit, Firefox 53.0 32 bit e Chrome 58.0.3029.96 64bit; su entrambi i bràuserz non vedo né numero dell'elemento Wikidata sotto il titolo né il nome della sua etichetta né titoli alternativi; non vedo l'anteprima di una voce passando con il mouse sul link; non vedo una voce in anteprima in modalità edit testo evidenziando il wikilink nel codice con doppie parentesi quadre; non vedo gli elementi aggiuntivi del menu di sinistra; non mi funziona HotCat; l'unica cosa che mi funziona sono gli evidenziatori di disambigue e quelli di redirect errati. -- SERGIO (aka the Blackcat) 19:31, 6 mag 2017 (CEST)

Aggiornamento con workaround: ho pulito da monobook.js la variabile "toLoad; ho eliminato in Preferenze tutti i gadsgs gasget tutte le cose strane e ho sloggato, pulito la chéish e poi sono rientrato, ho rimesso i gadsgs vabbe', quelle cose lì, e pare funzionare. -- SERGIO (aka the Blackcat) 19:45, 6 mag 2017 (CEST)
HotCat si può usare, non dovrebbe causare problemi.--Sakretsu (炸裂) 20:19, 6 mag 2017 (CEST)
Ok, pare che abbia ripreso a funzionarmi HotCat e il popup di navigazione. -- SERGIO (aka the Blackcat) 11:46, 7 mag 2017 (CEST)
Risolto "quasi" del tutto. Mi sembra che l'unica cosa da sistemare sia il fatto che proprio non mi vuole funzionare il template {{titolo errato}} (ad esempio nel Wikipediano). --Roberto Segnali all'Indiano 14:42, 7 mag 2017 (CEST)
Ho disattivato e poi riattivato Hotcat e i popup, ma continua a non esserci la barra di modifica in alto (oltre a chiedermi ogni volta conferma per gli OS, l'assenza di suggerimenti nella barra di ricerca e il non funzionamento dei gadget ma questi sono inconvenienti minori). Si può risolvere? Grazie. R5b43 (msg) 17:53, 7 mag 2017 (CEST)
Da ieri sera sembra che i vari inconvenienti da me (e da altri) riscontrati siano terminati. Per lo meno usando Firefox. --Pracchia 78 (scrivimi) 21:40, 8 mag 2017 (CEST)
Anche da me pare che il problema non si verifichi più. E' stata fatta qualche correzione a MediaWiki:Common.js --Bultro (m) 18:06, 9 mag 2017 (CEST)

[ Rientro] Segnalo che a me i popup non funzionano se abilito anche il gadget "Permette di recuperare la definizione da Wikizionario tramite un doppio click" (dictionaryLookupHover). Confermate questo conflitto? --Horcrux九十二 18:25, 10 mag 2017 (CEST)