Wikipedia:Bar/Discussioni/Inquietante avviso rosso, che fare?

Da Wikipedia, l'enciclopedia libera.
Jump to navigation Jump to search

Inquietante avviso rosso, che fare?


Allora allora, il nostro competente e valoroso amministratore Daimona Eaytoy ha fatto una serie di magheggi che non sto a spiegarvi (perché non ne sarei in grado) ma il risultato è che a molti utenti è apparso in fondo alla casella di modifica un vistoso avviso rosso con delle scritte inquietanti e minacciose.

Don't panic! Si può - anzi, si deve - risolvere!

Tutto ciò che dovete fare è:

  • Andare nelle preferenze e attivare qui la funzione corrispondente ad ogni sigletta presente nell'avviso. È facile: nel brutto avviso rosso, accanto ad ogni sigletta, c'è un link. Cliccandolo si aprirà la descrizione degli accessori da attivare. Cercate quella descrizione nelle preferenze e piazzategli una spunta accanto per attivare l'accessorio.
  • Aprite i vostri file .js: Speciale:MiaPaginaUtente/common.js, Speciale:MiaPaginaUtente/vector.js e Speciale:MiaPaginaUtente/monobook.js. NB: non è detto che esistano tutti, prendete in considerazione solo quelli esistenti.
  • In uno (o più) di questi file ci sono delle righe che iniziano con var toLoad e importScript('Wikipedia:Monobook.js/MonobookCompleto.js'). Rimuovetele tutte.

Quelle siglette lì corrispondono a delle funzioni che ora, nei tempi moderni, sono attivabili nelle preferenze tramite gli accessori, ecco perché vanno rimosse.

Facile, no? Se ce l'hanno fatta utenti anzyani e un po' rimbambiti ce la può fare chiunque!

Grazie per il vostro aiuto, anche oggi avete contribuito a rendere Wikipedia un posto migliore (e avete fatto la felicità degli smanettoni)

(Post scritto a più mani da Daimona Eaytoy, Parma1983 e Civvì) --Civvì (Parliamone...) 18:34, 1 nov 2018 (CET)

FAQ[modifica wikitesto]

  • Q: Vabbbene, ma dato che a me non me ne può frega' di meno, non lo potete fare voi smanettoni?
  • A: Potremmo far sparire le siglette (e quindi l'avviso) ma poi solo tu puoi modificare le tue preferenze. Per continuare ad usare Wikipedia come lo fai adesso, devi essere tu ad attivare i nuovi accessori.

  • Q: Ma se a me il modulare piace tanto? Perché devo toglierlo?
  • A: Vedi sotto per una spiegazione lievemente tecnica. In soldoni: crea problemi sia a chi deve aggiornarlo sia a te che lo usi. (Tradotto: fidati dei nostri smanettoni che sono bravi!)
Perché eliminare il monobook modulare
  • Difficile da leggere per chi deve tenerlo aggiornato
  • Usa roba vecchia che quando va bene spamma di avvisi la console (aka intristisce il vostro browser), quando va male dà errore e non funziona nulla
  • Essendo definito nel namespace Wikipedia, rende vani gli AI e il loro scopo
  • Importa pezzi di script a destra e a manca, a differenza degli accessori che sono ben compartimentati e (solitamente) indipendenti
  • Presenta(va) falle di sicurezza che permettevano allaggente di fottersi il vostro bellissimo account e quelli degli altri utenti (no, senza esagerazioni)

  • Q: Devo toglierlo subito?
  • A: Sarebbe l'ora... Lo script è deprecato dal 2014, sarebbe meglio evitare ulteriori attese (Vuoi rompere linternet? No, vero?) :-D

  • Q: Cosa succede se non lo faccio?
  • A: Sarai maggiormente esposto a vari problemi, quali malfunzionamenti dei tool utilizzati e problemi di sicurezza. Inoltre si presenteranno alla tua porta tutti gli admin con aria molto minacciosa...

  • Q: Ho fatto visita alle mie preferenze, ma uno o più degli accessori segnalati sono già attivati. Cosa devo fare?
  • A: Ignorali e procedi con gli altri. Se sono tutti già attivati, devi solo cancellare i pezzi segnalati sopra dalle tue pagine JavaScript.

  • Q: Anziché cancellare le siglette dal JavaScript, posso limitarmi a commentarle (inserendo // a inizio riga)?
  • A: In teoria sì, e sortiresti l'effetto voluto. Tuttavia, il risultato finale è lo stesso, e cancellando del tutto la riga diventa più semplice utilizzare la ricerca per identificare gli utenti che ancora devono modificare il loro JavaScript.

  • Q: Sìììì bravissimi, ma io ancora non c'ho capito nulla
  • A: Se hai una domanda, passa in officina

  • Q: Ho fatto tutto ciò che dovevo fare, ma qualcosa non funziona e/o continuo a ricevere l'avviso rosso
  • A: Per prima cosa, prova ad aspettare qualche minuto, seguendo queste istruzioni. Se i problemi rimangono, spiegali in officina

Discussione[modifica wikitesto]

Altra nota aggiuntiva: se nei vostri file .js compare una riga del tipo:
import ("''qualcosa''/monobook.js")
cancellatela oppure scrivete due slash senza spazio (così: "//") prima della parola "import". Anche questo può contribuisce a far comparire/sparire l'avviso rosso. Non temete, la rimozione di questa riga non ha effetti collaterali indesiderati. --L736El'adminalcolico 18:38, 1 nov 2018 (CET)
[@ L736E] Ti ho spostato qui sotto :-) Il consiglio sopra però è prematuro: i gadget non sono ancora tutti sostituibili e rimuovere l'importazione di script del modulare può effettivamente portar via delle funzionalità. In effetti, sopra non c'è scritto ma in futuro ci sarà una seconda fase per la rimozione del modulare. --Daimona Eaytoy (Scrivimi!) 18:47, 1 nov 2018 (CET)
Solo che se non rimuovi l'importazione, continua ad apparire il messaggio rosso: dopo aver eliminato i "load" non più necessari, il messaggio continuava a comparirmi. È sparito solo dopo aver rimosso l'import.--L736El'adminalcolico 21:09, 1 nov 2018 (CET)
[@ L736E] Strano, non dovrebbe accadere. Lo script (che, ammetto, non ho scritto bene) avvisa solo se il toLoad contiene determinate stringhe... Magari era un problema di cache? Domani controllo meglio. --Daimona Eaytoy (Scrivimi!) 22:12, 1 nov 2018 (CET)
Piccola nota per i piú pigri, posso direttamente richiedere la cancellazione per le sottopagine monobook dopo aver attivato le preferenze? --Paul Gascoigne (msg) 10:58, 2 nov 2018 (CET)
[@ Paul Gascoigne] Certamente, se non c'è rimasto nulla che ti serve :-) Puoi comunque anche limitarti a svuotarle, se preferisci mantenere la crono. --Daimona Eaytoy (Scrivimi!) 11:04, 2 nov 2018 (CET)